I understand that naming conventions are important for a number of reasons, most having to do with making your code more readable and easier to integrate into larger projects, etc. In Java, most conventions require that method names be in lowerCamelCase
begin with a verb.
My question is: how do I choose the verb to begin the method name?
To make this question less vague, I'm often in the situation where my first choice for a method name is a noun describing the output. In these cases, I'm usually torn between appending generic verbs such as get
, generate
, calculate
, etc in font of the noun to conform to the verb rule. Are there general guidelines for when to use which?
Here's an example. I have a method that takes double[] array
and an int k
and returns double[] newArray
which is the length k
moving average of array
, i.e. newArray[i] = (array[i-k+1]+...+array[i])/k
with some fudging to make newArray
the same length as array
. My inclination is to call this method movingAverage
since that's what it returns, but that's out since it doesn't begin with a verb. Should I call this method getMovingAverage
or generateMovingAverage
or calculateMovingAverage
or does it not really matter?
Methods should be verbs, in mixed case with the first letter lowercase, with the first letter of each internal word capitalized. Except for variables, all instance, class, and class constants are in mixed case with a lowercase first letter. Internal words start with capital letters.
Java uses CamelCase as a practice for writing names of methods, variables, classes, packages, and constants.
CamelCase in Java naming conventions Java follows camel-case syntax for naming the class, interface, method, and variable. If the name is combined with two words, the second word will start with uppercase letter always such as actionPerformed(), firstName, ActionEvent, ActionListener, etc.
I usually ask myself:
What is this method doing?
The answer dictates what the method should be called. It is completely independent of the programmer, of course.
Note: If you can't succinctly describe what the method is doing, it's probably doing too much and should be split up.
Choosing your method's verb:
Now, not all methods begin with a verb; but they really don't need to. If you read:
... myString.length();
or
... myArray.size();
you know exactly what is going on - no verb required. This is true for many class methods higher up in the Java hierarchy; Collections, Math, etc. As long as the name accurately communicates what the method does, it's fine.
Do not forget to use this verbs "is, has or can" for boolean methods, such as: isOn(), isFull(), and so on.
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With