For synchronous getter functions, the naming convention is well-defined:
var getFerby = function(){
..
return ferby;
};
However, if the ferby I want is not locally (synchronously) available, a common method is to handle that situation with a callback:
/**
* Asynchronously gets a ferby and passes it to the callback.
*
* Once the ferby is retrieved, these rules MUST be followed:
* 1) Don't feed it after midnight.
* 2) Don't give it water.
* 3) Don't let it near bright light.
*
* @param {ferbyCallback} callback - The callback function that expects a ferby.
*/
var fooFerby = function(callback){
getFerbyLoader().load(function(ferby){
callback(ferby);
});
};
/**
* The callback for the fooFerby function.
*
* @callback ferbyCallback
* @param ferby The ferby
*/
What is a good naming convention for fooFerby
so that I know by name that it expects a callback?
I use the prefix "fetch", instead of "get" for asynchronous getters.
The idea is that if it is not locally available, you need to fetch it.
.NET uses BeginDoAction. I like the same approach in JavaScript. So in your case, the function would be beginGetFerby
.
NodeJs takes the convention that most methods are asynchronous, and the synchronous methods have a 'Sync' suffix, e.g. doActionSync. You could do the opposite, and have an 'Async' suffix, so your function would be getFerbyAsync
. I like that approach too.
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With