So I have something called
exports.create = function(projectJSON){
var project = new ProjectModel({
id : projectJSON.id,
projectName : projectJSON.projectName ,
authorName : projectJSON.authorName,
firstPostDate : projectJSON.firstPostDate
})
}
Is the above naming convention for a multi-word element firstPostDate
(camel case) correct, or should they be spaced with _
in all lowercase?
I see that other blogs prefer it to be in small caps..
EDIT:
Also I read that elements should be singular instead of plural ie:
`comment` instead of `comments` for a blog schema design
I use Google's JSON Style Guide myself and they suggest using camelCase i.e. firstPostDate. Below is the section excerpt
Property Name Format
Property names must conform to the following guidelines:
These guidelines mirror the guidelines for naming JavaScript identifiers. This allows JavaScript clients to access properties using dot notation. (for example, result.thisIsAnInstanceVariable). Here's an example of an object with one property:
{
"thisPropertyIsAnIdentifier": "identifier value"
}
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With