Logo Questions Linux Laravel Mysql Ubuntu Git Menu
 

Suggest me a better name for an API method

Introduction:

I'm working on an API which provides access to Picasa, Flickr and some other image services.

I have a class WebAlbum (it provides access to nested photos, albums if allowed, and some meta information).

My API allows the user not only to read albums but it also allows them to create new albums. In the general case, in order to create new album, the API user should use a factory method, which creates an album and then call the method WebGallery#addAlbum (newAlbum).

But Flickr doesn't allow creation of empty albums, it requires at least one predefined photo in any new album (to make nice album preview probably). In Flickr terms this first photo is called the Primary Photo. So in order to create an album for Flickr, user should use a factory method, then add an image to the new album, and then call WebGallery#addAlbum (newAlbum).

Problem:

At the moment WebAlbum class has this method

public interface WebAlbum {

   ...

   public boolean requiresPrimaryPhoto ();
}

I can't leave this name because PrimaryPhoto is just a Flickr term. I can change it to

public interface WebAlbum {

   ...
   //with spaces: requires one added photo to create new album

   public boolean requiresOneAddedPhotoToCreateNewAlbum ();
}

Please suggest a shorter name which has the same meaning.

like image 298
Roman Avatar asked Dec 03 '22 13:12

Roman


1 Answers

boolean isEmptyAlbumAllowed

like image 97
aw crud Avatar answered Dec 28 '22 01:12

aw crud