I'm wondering is there a way we can chain a method using (&:method)
For example:
array.reject { |x| x.strip.empty? }
To turn it into:
array.reject(&:strip.empty?)
I prefer the shorthand notation, due to its readability.
No, there's no shorthand for that. You could define a method:
def really_empty?(x)
x.strip.empty?
end
and use method
:
array.reject(&method(:really_empty?))
or use a lambda:
really_empty = ->(x) { x.strip.empty? }
array.reject(&really_empty)
but I wouldn't call either of those better unless you have a use for really_empty?
in enough places that splitting up the logic makes sense.
However, since you're using Rails, you could just use blank?
instead of .strip.empty?
:
array.reject(&:blank?)
Note that nil.blank?
is true whereas nil.strip.empty?
just hands you an exception so they're not quite equivalent; however, you probably want to reject nil
s as well so using blank?
might be better anyway. blank?
also returns true for false
, {}
, and []
but you probably don't have those in your array of strings.
It would be quite nice to write the above like that but it's not a supported syntax, the way that you would want to chain methods using the to_proc syntax (&:) is like so:
.map(&:strip).reject(&:empty?)
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With