I am using a function in a class as below
- (void) uploadMorePic:(NSDictionary *) MuliPics: (NSData *)file
It shows the warning - MuliPics
used as the name of the previous parameter rather than as part of the selector
Why that comes ?
It's a poor message, but it's because you didn't provide a name for the first parameter to your method. Try this:
-(void)uploadMorePic:(NSDictionary *)dict muliPics:(NSData *)file
I also fixed a style issue; the name of the second part of the method name should start with a lower-case letter. I don't know what your method does, so you may be able to come up with a better name.
Because you haven't separately specified the parameter name and the selector definition. Basically, you're missing a space and/or a word. Try:
-(void)uploadMorePictures:(NSDictionary *)pics withFile:(NSData *)file
Which separately names and specifies both parameters to the method.
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With