Very simple question, but I want to start using a consistent naming convention for validation methods and I can't think of the best way!
Do people tend to use IsDataValid() style? or are there any others that are more descriptive and meaningful?
Cheers
It depends what your validation method does.
If it returns a Boolean, then probably starting with Is
and ending with Valid
is a good place to start. Using is
for Boolean calls generally leads to readable code in if
statements.
If your validation method throws an exception, then I'd usually start the method name with something like Check
instead.
However, also worth considering (as methods should usually use verbs) is beginning the method name with Validate
. The Is
style is generally more applicable to properties.
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With