Does Cocos2d have any naming conventions for variables?
I have this
//.h
NSMutableArray *newRowForCounter;
and
//.m
@synthesize newRowForCounter;
At @synthesize
it's warning me that "property's synthesized getter follows cocoa naming convention for returning 'owned' objects". If I change the name to something else, it work fine.
new cannot be used in the variable name at the beginning. That is why it shows the error.
Sol : declare a property whose name begins with new unless you specify a different getter:
// Won't work:
@property NSString *newTitle;
// Works:
@property (getter=theNewTitle) NSString *newTitle;
Explanations here and here
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With