I have been facing this problem of no internet in the Windows 10 virtual machine. I am running VMWare Fusion on a Macbook Pro. I have tried restarting Win10 VM, VMWareFusion, but nothing works.
After wasting close to 10 hours of restarting the machines, adding Network Adapters, etc and of course googling and searching here on StackOverflow, Finally the following works.
(Your VMWare Fusion and Windows 10 VM can be running)
Voila!! end of Problems!
I started experiencing this issue when upgraded my Mac Book Pro. I upgraded from macOS Big Sur 11.5 to macOS Big Sur 11.6
When I opened up my VMWare Fusion and started my Ubuntu virtual machine I realized that the virtual machine no longer connects to the host machine's internet connection automatically.
Here are the few things I first tried that did not work
sudo kextload /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext/
and restarted my Mac Book for the extensions to be enabled. Then I ran the following command as well: kextstat | grep vm
Here are the last things I tried that finally made it work for me:
First, I navigated to the VMWare Fusion application directory:
cd /Applications/VMware\ Fusion.app/Contents/Library
Next, I ran the command below to check the status of vmnet:
sudo vmnet-cli --status
I got the result below which showed that they were off:
DHCP service on vmnet1 is not running
Hostonly virtual adapter on vmnet1 is disabled
DHCP service on vmnet8 is not running
NAT service on vmnet8 is running
Hostonly virtual adapter on vmnet8 is disabled
Some/All of the configured services are not running
Next, I tried to stop and start it using the command below:
sudo vmnet-cli --stop
sudo vmnet-cli --start
I got the output below from the operation:
Enabled hostonly virtual adapter on vmnet1
Started DHCP service on vmnet1
Started NAT service on vmnet8
Enabled hostonly virtual adapter on vmnet8
Started DHCP service on vmnet8
Started all configured services on all networks
But when I ran the command below to check the status of vmnet:
sudo vmnet-cli --status
I got the result below again which showed that they were off:
DHCP service on vmnet1 is not running
Hostonly virtual adapter on vmnet1 is disabled
DHCP service on vmnet8 is not running
NAT service on vmnet8 is running
Hostonly virtual adapter on vmnet8 is disabled
Some/All of the configured services are not running
Finally, I tried running the command from jai's answer:
sudo spctl --master-disable
Note: spctl
is a command-line interface to the same security assessment policy subsystem that Gatekeeper uses. Like Gatekeeper, spctl will only accept Developer ID-signed apps and apps downloaded from the Mac App Store by default. It will reject apps signed with Mac App Store development or distribution certificates. You can read up more here: macOS Code Signing In Depth
Next, I shut down (not restarted) my Mac Book and then turned it on again. This time the Ubuntu virtual machine was able to connect to the host machine's internet connection automatically.
You can enable spctl
again (which is what I did) using the command below:
sudo spctl --master-disable
and watch to see if things are fine, else, you may have to disable again.
You can also check the status of spctl
using the command below:
sudo spctl --status
That's all
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With