I have a lot developed in .NET windows forms and they are each named whatever they are with no prefixes. However, I often find myself needing to declare another class that contains the column names that the form uses.
For instance, I have a class called Address, which is a form for the maintenance of addresses. However, I also need a class that I'd like to also call Address that basically just contains the declarations of Name and Address fields. I am looking for a good naming convention to differentiate between the two (the class definition vs. the form).
The normal convention for Windows Forms is to suffix the names of form classes with Form
. So, your class for address should be called just Address
(because, after all, it is an address), but the form that is used to edit addresses should be AddressForm
(or AddressListForm
, or AddressEditorForm
, etc - depends on what exactly it does).
Maybe this?
class Address { }
class AddressForm { }
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With