Logo Questions Linux Laravel Mysql Ubuntu Git Menu
 

Naming conventions for boolean attributes

I want to write code that others easily can understand as well.

Do boolean attributes like hide_email or email_hidden have a convention style?

like image 513
Fellow Stranger Avatar asked May 05 '16 20:05

Fellow Stranger


People also ask

How do you name boolean properties?

✔️ DO name Boolean properties with an affirmative phrase ( CanSeek instead of CantSeek ). Optionally, you can also prefix Boolean properties with "Is", "Can", or "Has", but only where it adds value. ✔️ CONSIDER giving a property the same name as its type.

How do you name a boolean variable in Java?

Boolean variables should be prefixed with 'is' This is the naming convention for boolean methods and variables used by Sun for the Java core packages. Using the is prefix solves a common problem of choosing bad boolean names like status or flag.

What are the naming conventions for variables?

A variable's name can be any legal identifier — an unlimited-length sequence of Unicode letters and digits, beginning with a letter, the dollar sign " $ ", or the underscore character " _ ". The convention, however, is to always begin your variable names with a letter, not " $ " or " _ ".


4 Answers

I think of it like this:

  • A boolean attribute should answer a simple yes/no question.
  • Asking "is?" is a simple way to ask a yes/no question.
  • So a boolean attribute name should complete the sentence is <attribute_name>
  • Then just remove the is because Ruby prefers the ? suffix for "is"-style method names (see below for more), leaving you with just email_hidden

So, for your specific case, name your attribute like this:

  • Start with the question "email is hidden"?. Which can be represented in code as: email_is_hidden.
  • Remove the is and you're left with email_hidden
  • Ruby on Rails defines a "predicate" version (one that ends in a ?) of your boolean attribute and returns true/false as expected. So, while your attribute is named email_hidden in the database you should reference it as email_hidden? in your code for clarity and as is the Ruby on Rails convention.
like image 194
pdobb Avatar answered Oct 04 '22 11:10

pdobb


Taking these two examples of names you gave:

  • hide_email would be a good name for a method performing such a task, a method that executes all the procedures to hide an email in the scope of your system. But it would never be a good name for a boolean method returning the state of an e-mail.
  • email_hidden?, with a question mark (?) at the end, would be the correct name for a boolean method indicating if the e-mail is hidden or not.

Always consider Ruby conventions if you really want to write good code. They will help you even when thinking about the processes in your system.

like image 20
Ed de Almeida Avatar answered Oct 04 '22 11:10

Ed de Almeida


That would be email_hidden?. It is what Ruby community got used to.

Please note the ? at the end.

like image 2
Uzbekjon Avatar answered Sep 30 '22 11:09

Uzbekjon


The ruby code smeels said that all boolean methods should finish with ?

On active record you could see

User.valid?

Or in ruby you could find

[].nil?
[].empty?

If you want to know about Ruby's conventions read this

http://blogs.visoftinc.com/2010/04/12/ruby-beauty-method-naming-conventions/

like image 2
Horacio Avatar answered Oct 02 '22 11:10

Horacio