I would like to give a good name to class that will contain both methods for encryption and decryption using the same alghoritm. Does anyone have an idea for naming seemingly opposing expressions under one term?
I found a name for class that encodes and decodes a string of characters, ie. "codec" (COder-DECoder). I dont want to use the codec term for encryption operations if I already used it for character encoding.
Methods will be something like:
NameOfTheClass.Encrypt(string plainText);
NameOfTheClass.Decrypt(string cipherText);
Such classes are usually named after the cipher they implement. If you have a base class with virtual methods that will be implemented by several different cipher classes, that class usually has a name like BlockCipher
or something, depending on exactly what you are doing with it.
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With