Logo Questions Linux Laravel Mysql Ubuntu Git Menu
 

Form handling and validation in pure JavaScript

My intention is to get your thoughts and criticism about the script below, as regards the algorithm's design, performance and cross-browser compatibility.

I have just started getting into JavaScript having missed out on its awesomeness for quite a while. My background and experience is in developing C/C++/PHP based RESTful backends.

In order to understand the language and the right way of using it, I decided to do something which I am sure has been done many times before. But learning to use a new language and paradigm often entails pain anyway.

This is my attempt to create a normal form processing and validation script/ function. In order to reduce complexity and keep code simple/clean, I decided to use HTML5 Custom Data Attributes (data-*) to assign metadata for each element in the form:

  1. Data-Required: True or False. If set to true, this parameter makes the form-field required and so it cannot be empty. A value set to false indicates that the field is optional. Default is false.>

  2. Data-Type: Type of validation to be performed. Examples include 'email', 'password', 'numbers' or any other 'regexp'.

A fairy simple example of such a form would be:

<form action="postlistings" id="postlistings" enctype='multipart/form-data' method="post" class="postlistings">
    <ul class="login-li">
        <li>
            <input class="title" name="title" type="title" id="title" data-required="true" data-type="title"></a>
        </li>
        <li>
            <textarea name="body" id="elm1" class="elm1" name="elm1" data-type="body" data-required="true" >
            </textarea>
        </li>
        <li>
        <span class="nav-btn-question">Add Listing</span>
        </li>
    </ul>
</form>

Reminder: This is my first piece of JavaScript code. The idea is to call Form while passing the form name to retrieve and validate all the field values in one loop for performance. The validation involves two steps as can be guessed from the Data-* attributes described above:

i. Check for required form fields.

In case the values fail to meet step 1 requirement, an error message from configuration is pulled for the specific form value. Thus, for all values that fail to meet this requirement, an array of error messages are collected and passed on to the View.

ii. Perform respective validations.

Validations are only performed if all the values passed step 1. Otherwise, they follow the same steps as indicated in 1 above.

function Form(){

    var args = Array.prototype.slice.call(arguments),
        formName = args[0],
        callback = args.pop(),
        userError = [{type: {}, param: {}}],
        requiredDataParam = 'required',
        typeDataParam = 'type',
        form = document.forms[formName],
        formLength = form.length || null,
        formElement = {id: {}, name: {}, value: {}, required: {}, type: {}};

    function getFormElements(){
        var num = 0;
        var emptyContent = false;
    
        for (var i = 0; i < formLength; i += 1) {
        
            var formField = form[i];
            formElement.id[i] = inArray('id', formField) ? formField.id : null;
            formElement.name[i] = inArray('name', formField) ? formField.name : null;
            formElement.value[i] = inArray('value', formField) ? formField.value : null;
            formElement.required[i] = getDataAttribute(formField, requiredDataParam);
            formElement.type[i] = getDataAttribute(formField, typeDataParam);
        
        
            if (formElement.required[i] === true){
                if(!formElement.type[i]) {
                    error('Validation rule not defined!');
                }
                else if (!formElement.value[i]) {
                    userError[num++] = {'type': 'required', 'param': form[i]};
                    emptyContent = true;
                }
            }
            
            if (emptyContent === false) {
                // Perform validations only if no empty but required form values were found.
                // This is so that we can collect all the empty
                // inputs and their corresponding error messages.
            }
    
        }
    
        if (userError) {
            // Return empty form errors and their corresponding error messages.
        }

        return formElement;
    };

    // Removed the getFormParam function that was not used at all.

    return {
        getFormElements: getFormElements
    }
};

Two outside functions that are used in the JS script above (from JQuery source):

var inArray = function(elem, array){
    if (array.indexOf){
        return array.indexOf(elem);
    }

    for (var i = 0, length = array.length; i < length; i++){
        if (array[i] === elem){
            return i;
        }
    }

    return -1;
} 


// This is a cross-platform way to retrieve HTML5 custom attributes.
// Source: JQuery

var getDataAttribute = function(elem, key, data) {
    if (data === undefined && elem.nodeType === 1) {
        data = elem.getAttribute("data-" + key);
    
        if (typeof data === "string") {
            data = data === "true" ? true :
            data === "false" ? false :
            data === "null" ? null :
                !CheckType.isNaN ? parseFloat(data) :
                CheckType.rbrace.test(data) ? parseJSON(data) :
                data;
        }
        else {
            data = undefined;
        }
    }
    return data;
}

An example of Config Error messages can be set as follows:

var errorMsgs = {
    ERROR_email: "Please enter a valid email address.",
    ERROR_password: "Your password must be at least 6 characters long. Please try another",
    ERROR_user_exists: "The requested email address already exists. Please try again."
};

As I post this for your review, please ignore any styling conventions that I might not have followed. My intention is to get your expert reviews on anything I should be doing different or could do better concerning the code itself, and the algorithm.

Besides the styling conventions, all criticism and questions are welcome.

like image 404
goodMan Avatar asked Dec 15 '22 10:12

goodMan


2 Answers

First I'd like to clear up a common misconception. Forgive me if you already understand this clearly; maybe it will be helpful for someone else.

Learning and using jQuery or a similar library does not preclude or conflict with learning the JavaScript language. jQuery is simply a DOM manipulation library which takes away many of the pain points of using the DOM. There's plenty of room to learn and use JavaScript, the language, even if you use a library to abstract away some of the DOM details.

In fact, I would argue that using the DOM directly is likely to teach bad JavaScript coding habits, because the DOM is very much not a "JavaScript-ish" API. It was designed to work identically in JavaScript and Java and potentially other languages, and so it completely fails to make good use of the features of the JavaScript language.

Of course as you said, you're using this as a learning exercise; I just don't want you to fall into the trap that I've seen many people fall into of thinking, "I don't want to learn jQuery, because I want to learn JavaScript instead!" That's a false dichotomy: you have to learn JavaScript in either case, and using jQuery for the DOM doesn't interfere with that at all.

Now some details...

While it's OK to quote property names in an object literal and when you reference the properties, it's customary - and more readable - not to quote them when they are valid JavaScript names. e.g. in your formElement object

formElement = { id: {}, name: {}, value: {}, required: {}, type: {} };

(there was a missing semicolon at the end there too)

and where you use the names you can do:

formElement.id[i] = ...
formElement.name[i] = ...

etc.

Don't run your loops backwards unless the program logic requires it. It doesn't make the code faster except possibly in the case of an extremely tight loop, and it makes it unclear whether you're just prematurely optimizing or actually need the backwards loop.

Speaking of optimization, that loop has several inArray() calls. Since each of those loops through an array, that could be more of a performance impact than the outer loop. I imagine these arrays are probably pretty short? So performance wouldn't matter at all anyway, but this is something to think about in cases where you have longer arrays and objects. In some cases you can use an object with property names and values for a faster lookup - but I didn't look closely enough at what you're doing to suggest anything.

In any case, you're using inArray() wrong! But not your fault, that is a ridiculously named function in jQuery. The name clearly suggests a boolean return value, but the function returns the zero-based array index or -1 if the value is not found. I strongly recommend renaming this function as indexOf() to match the native Array method, or arrayIndex(), or some such.

That same loop has form[i] repeated numerous times. You could do this at the top of the loop:

var field = form[i];

and then use field throughout, e.g. field.id instead of form[i].id. This is generally faster, if it matters (which it probably doesn't here), but more importantly it's easier to read.

Do not use strict boolean comparisons like if( foo === true ) and if( bar === false) unless you really need to - and those cases are rare. The code sends a signal to the reader that there is something going on that's different from the usual boolean test. The only time these particular tests should be used is when you have a variable that may contain a boolean value or may contain some other type of value, and you need to distinguish which is which.

A good example of a case where you should use tests like these is an optional parameter that defaults to true:

// Do stuff unless 'really' is explicitly set to false, e.g.
// stuff(1) will do stuff with 1, but stuff(1,false) won't.
function stuff( value, really ) {
    if( really === false ) {
        // don't do stuff
    }
    else {
        // do stuff
    }
}

That specific example doesn't make a lot of sense, but it should give you the idea.

Similarly, an === true test could be used in a case where need to distinguish an actual boolean true value from some other "truthy" value. Indeed, it looks like this line is a valid case for that:

if (formElement['required'][i] === true){

given that if (formElement['required'][i] comes from the getDataAttribute() function which may return a boolean or other type.

If you are just testing for truthiness, though - and this should be most of the time - simply use if( foo ) or if( ! foo ). Or similarly in a conditional expression: foo ? x : y or !foo ? x : y.

The above was a long-winded way of saying that you should change this:

if (empty_content === false) {

to:

if (!empty_content) {

Your getFormParam() function goes to some work to convert an undefined result to null. There is usually no reason to do this. I don't see any place where that function is called, so I can't advise specifically, but in general you'd be testing for truthiness on something like this, so null and undefined would both be treated as false. Or in cases where you do need to distinguish null/undefined from other values (say, an explicit false), you can easily do it with != null or == null. This is one case where the "looser" comparison performed by == and != is very useful: both null and undefined evaluate the same with these operators.

You asked to ignore coding style, but one little suggestion here: You have a mix of camelCaseNames and names_with_underscores. In JavaScript, camelCaseNames are more idiomatic for function and variable names, with PascalCaseNames for constructor functions. Of course feel free to use underscores where they make more sense, for example if you're writing code that works with database columns in that format you may want your variable names to match the column names.

Hope that helps! Keep up the good work.

Update for your new code

I'm having a bit of trouble following the logic in the code, and I think I know part of the reason. It's a combination of naming conventions and inside-out objects.

First, the name formElement is really confusing. When I see element in JavaScript, I think of either a DOM element (HTMLElement) or an array element. I'm not sure if this formElement represents one or the other or neither.

So I look at the code to figure out what it's doing, and I see it has id:{}, name:{}, ... properties, but the code later treats each of those as an Array and not an Object:

formElement.id[i] = ...
formElement.name[i] = ...
formElement.value[i] = ...
formElement.required[i] = ...
formElement.type[i] = ...

(where i is an integer index)

If that code is right, those should be arrays instead: id:[], name:[], ....

But this is a red flag. When you see yourself creating parallel arrays in JavaScript, you're probably doing it wrong. In most cases you're better off replacing the parallel arrays with a single array of objects. Each of the objects in that array represents a single slice through all your parallel arrays, with a property for each of the previous arrays.

So, this object (where I've made the correction from {} to [] to match its current use):

formElement = { id: [], name: [], value: [], required: [], type: [] };

should be:

formInfo = [];

and then where you have the code that goes:

formElement.id[i] = ...;
formElement.name[i] = ...;
formElement.value[i] = ...;
formElement.required[i] = ...;
formElement.type[i] = ...;

It should be:

var info = {
    id: ...,
    name: ...,
    value: ...,
    required: ...,
    type: ...
};
formInfo.push( info );

and adjust the rest of the code to suit. For example:

formElement.required[i]

would be:

formInfo[i].required

or even simpler since it's in the same function:

info.required

And note: I'm not saying info and formInfo are great names :-) they are just placeholders so you can think of a better name. The main idea is to create an array of objects instead of a set of parallel arrays.

One last thing and then I'm out of time for now.

That getDataAttribute() function is a complicated little piece of work. You don't need it! It would be simpler would just call the underlying function directly where you need it:

var info = {
    ...
    required: formField.getAttribute('data-required') === 'true',
    type: formField.getAttribute('data-type')
};

This also gives you full control of how the attributes are interpreted - as in the === 'true' test above. (This gives you a proper boolean value, so when you test the value later you don't have to use === true on it.)

On a stylistic note, yes, I did hard code the two 'data-xxxx' names right there, and I think that's a better and more clear way to do it.. Don't let your C experience throw you off here. There's no advantage to defining a string "constant" in this particular case, unless it's something that you want to make configurable, which this isn't.

Also, even if you do make a string constant, there's a minor advantage to having the complete 'data-whatever' string instead of just 'whatever'. The reason is that when somebody reads your HTML code, they may see a string in it and search the JS code for that string. But when they search for data-whatever they won't find it if the data- prefix is automagically prepended in the JS code.

Oh, I forgot one last thing. This code:

function Form(){

    var args = Array.prototype.slice.call(arguments),
        formName = args[0],
        callback = args.pop(),

is working way too hard! Just do this instead:

function Form( formName, callback ) {

(and keep the var for the remaining variable declarations of course)

like image 118
Michael Geary Avatar answered Dec 18 '22 12:12

Michael Geary


I cannot add comments yet so here is a little tip. I would separate the getFormElements() into smaller private functions. And I would add the errorMsgs to the Form function.

But for a first script in JavaScript, it is very impressive. This is actually the real reason I respond. I think it deserves more upvotes, and I would be very interested in a JS ninja responding to this question.

Good luck!

like image 20
user Avatar answered Dec 18 '22 11:12

user