I have a project with two subprojects. In one, I want to use sbt-docker, in the other, sbt-native-packager. However, they both define a key dockerCmd
with different types (String
and Seq[String]
respectively), so loading the project fails:
java.lang.RuntimeException: Some keys were defined with the same name but different types: 'dockerCmd' (scala.collection.Seq[java.lang.String], java.lang.String)
Is there a way around this easier than modifying the plugins to agree on the types?
See Plugins Best Practices:
Key naming convention: Use prefix
Sometimes, you need a new key, because there is no existing sbt key. In this case, use a plugin-specific prefix.
If you love us? You can donate to us via Paypal or buy me a coffee so we can maintain and grow! Thank you!
Donate Us With