Logo Questions Linux Laravel Mysql Ubuntu Git Menu
 

C# naming conventions for a recursive inner functions?

C# has a few naming conventions for commonly-seen method types:

  • BeginFoo() / EndFoo() for async methods
  • TryGet() / TryParse() that return false instead of throwing an exception
  • FooOrDefault() for methods that return default(T) instead of throwing an exception
  • IsFoo for boolean flags

I was wondering, is there one for recursive inner methods? e.g. in this example from another Stack Overflow question:

public int CalculateSomethingRecursively(int someNumber)
{
    return doSomethingRecursively(someNumber, 0);
}

// What to call this? 
private int doSomethingRecursively(int someNumber, int level)
{
    if (level >= MAX_LEVEL || !shouldKeepCalculating(someNumber))
        return someNumber;
    return doSomethingRecursively(someNumber, level + 1);
}

In C I have seen people use foo(...) + foo_r(...) as a convention. But how about in .NET?

like image 969
Richard Dingwall Avatar asked Oct 18 '11 21:10

Richard Dingwall


People also ask

What C is used for?

C programming language is a machine-independent programming language that is mainly used to create many types of applications and operating systems such as Windows, and other complicated programs such as the Oracle database, Git, Python interpreter, and games and is considered a programming foundation in the process of ...

Is C language easy?

Compared to other languages—like Java, PHP, or C#—C is a relatively simple language to learn for anyone just starting to learn computer programming because of its limited number of keywords.

What is the full name of C?

In the real sense it has no meaning or full form. It was developed by Dennis Ritchie and Ken Thompson at AT&T bell Lab. First, they used to call it as B language then later they made some improvement into it and renamed it as C and its superscript as C++ which was invented by Dr.


1 Answers

Personally I'd probably call it CalculateSomethingRecursivelyImpl - I tend to use Impl as a suffix for "the private method which actually does the bulk of the work of the method which has the same name but without the suffix." The fact that it's recursive wouldn't change that for me - but it's only a personal choice.

To be honest though, such a method would presumably always be private - so it doesn't matter nearly as much as for public / protected methods. Just work out a convention with your other team members.

like image 142
Jon Skeet Avatar answered Oct 14 '22 19:10

Jon Skeet